When attempting to install Bundler for Ruby on Ubuntu 10.04, I got the following error:
shell> sudo gem install bundler
ERROR: Error installing bundler:
bundler requires RubyGems version >= 1.3.6
sudo gem -v I saw that I had 1.3.5. To get around this, simply install the available updater gem, then run it:
shell> sudo gem install rubygems-update
shell> sudo /var/lib/gems/1.8/bin/update_rubygems
gem -v I see that I have 1.8.15 and I am able to install bundler:
shell> gem install bundler
Fetching: bundler-1.0.21.gem (100%)
Successfully installed bundler-1.0.21
1 gem installed
Installing ri documentation for bundler-1.0.21...
Installing RDoc documentation for bundler-1.0.21...